roby
roby
Offline
Resolved
0 votes
hi, i'm Roberto from Italy, and i'm new in this forum ... i have little experience in using MIDI...
i've just both a DTX700 drum kit (second-hand), and i'm trying to use it with MIDI. Unfortunately every DAW software that i use functions only with the General Midi Kit (kit number 50). With other kits i have problems with the HiHat (RHH 135)...
Is it normal ??? Is there a way to solve this problem ???

thank you

p.s. sorry for my english :p
Thursday, February 08 2018, 11:07 PM
Share this post:
Responses (7)
  • Accepted Answer

    David
    David
    Offline
    Thursday, February 08 2018, 11:32 PM - #Permalink
    Resolved
    0 votes
    it's down to getting a MIDI map for your DAW to map the other kits onto.

    I use Cakewalk and have MIDI Maps (INS Files) that map specific DTX kits to the appropriate MIDI numbers, You may find the equivalent for your DAW and kit. As a default, most DAWs understand GM (General MIDI maps), which define, for example, kick on note #36, snare on note#38 etc.
    https://www.midi.org/specifications/item/gm-level-1-sound-set
    The reply is currently minimized Show
  • Accepted Answer

    roby
    roby
    Offline
    Saturday, February 10 2018, 04:39 PM - #Permalink
    Resolved
    0 votes
    Thank you David for your reply... !!!

    unfortunately i'm almost completely new to MIDI mapping... to your knowledge, Is there any link or video-tutorial for dummies ???

    p.s. I downloaded MidiPipe, and i'm tryng to figure it out, but for now with bad results !!! :p

    Roby
    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Monday, February 12 2018, 01:07 PM - #Permalink
    Resolved
    0 votes
    Right - let's start from the beginning.

    What are you trying to achieve ?
    The reply is currently minimized Show
  • Accepted Answer

    roby
    roby
    Offline
    Tuesday, February 13 2018, 10:14 PM - #Permalink
    Resolved
    0 votes
    ok David... i'll try to explain myself the best that i can (considering my english) ...

    i want to use mi DTX700 for recording some MIDI tracks. but working with GarageBand, i've noticed that the only kit that doesn't give me problems (with the HiHat) is the General Midi Kit (kit number 50). I would love to manage to set up the other kits so they will function as well... i'm trying to use MidiPipe, and i'm slowly starting to understand how the mapping works. But i still have some doubts about HiHat mapping, because there are many parameters to set up: Close, Open, Half open, half closed etc etc, and the Rhh135 is a 2 zone pad, so i don't understand which parameter (note) i have to set and in which pad zone.

    i'm also trying to use Cubase Ai 9.5 (trial version), and i did not come upon the same problems as with GarageBand. Is it possible that Cubase does the auto-mapping ???

    thank you

    Roby

    Location [ View Larger Map ]

    The reply is currently minimized Show
  • Accepted Answer

    Wednesday, April 04 2018, 01:15 AM - #Permalink
    Resolved
    0 votes
    Roby or David, hello!

          My name is Daniel, from Brazil.
          This issue has been resolved? If so, how did they solve it? I also tried using a DTX700 kit with GarageBand, but the RHH135 hi-hat did not work well. It used to play very hard and exactly on top of the Yamaha logo, which resulted in a sound definitely without any dynamics.

    I also apologize for English ...

    Thank you!

    Daniel

    Location [ View Larger Map ]

    The reply is currently minimized Show
  • Accepted Answer

    David
    David
    Offline
    Monday, April 09 2018, 10:22 AM - #Permalink
    Resolved
    0 votes
    ...again, what are you trying to achieve? What's the end-game?
    The reply is currently minimized Show
  • Accepted Answer

    J
    J
    Offline
    Saturday, December 28 2019, 08:48 PM - #Permalink
    Resolved
    0 votes
    Hi Roberto,

    I too was having troubles with my Hi-Hat on my DTX700 kit recording into MIDI with Garageband. I am not exactly the most savvy on speaking MIDI language but I will try my best. Here was the problem/how I resolved it:

    I had a problem where when I used the preset drum kits provided by garage band, the edge of my hi-hat would not make sound in recording/playback. The top of the hi-hat and all other aspects registered fine but not having access to the edge of a hi-hat is pretty frustrating! Upon further assessment, the notes for the edge of the hi-hat were being recorded into Garageband onto the MIDI track but were going onto a note that does not have a sound designated to it.

    I resolved this issue by using MidiPipe to re-designate (remap) where the note was going. I remapped the edge open hi-hat note to the same as the middle open hi-hat note where I was getting sound. Then I did the same for the edge closed hi-hat to the middle closed hi-hat to have same sound.
    Refer to this video on how to do so:

    How To Remap MIDI in Garageband
    https://www.youtube.com/watch?v=jlD-GABPwso

    Also, if remapping more than 1 note, do the inputs/piping like this on MidiPipe:

    MIDI In
    Key Mapper
    AList
    MIDI Out
    MIDI In
    Key Mapper
    AList
    MIDI Out

    Hope this helps and isn't too confusing. Use the video though. Helped me a lot!
    The reply is currently minimized Show
Your Reply